Internet browser specification

Skip to section menu

Before using the MBRRACE-UK secure, web-based data entry system it is imperative that you check that you are using the correct internet browser i.e. the program that you use to access the internet.

In line with the Data Protection Act 1998 NHS rules around data security have been tightened considerably in recent years. Hence the MBRRACE-UK data entry system which has been designed to collect MBRRACE-UK data has very high levels of security in place to meet all the requirements of NHS Information Governance. We are aware that some Units are using computers which are running relatively old software which will not work properly with the MBRRACE-UK data entry system.

The main concern is in relation to the web browser, i.e. the program that you use to access the internet, as older versions are not able to provide sufficient security and will not run properly. However, we all have to comply with the NHS IG Toolkit standards with regard to secure data collection and so it is essential that information is entered via a computer with a browser that provides sufficient security.

What you need to do:

You must use a computer which has one of the following browsers to access the internet:

  • Internet Explorer (version 10 onwards)
  • Firefox (version 5.0 onwards)
  • Safari (version 5.0 onwards)
  • Chrome (version 12.0 onwards)
    Please contact your local IT support team if you do not have access to a suitable computer

N.B. The versions above are the minimum supported. We strongly encourage you to use the latest version wherever possible in order to maintain high standards of security.

If you are not sure how to find out which browser you are using then there are many helpful websites such as: http://www.bbc.co.uk/accessibility/guides/which_browser.shtml

Or you could ask your local IT support team.

For enquiries about internet access please contact MBRRACE-UK via email at mbrrace-uk@npeu.ox.ac.uk or telephone 01865 289715.